FSlogix Quicktip: Startmenü nach der zweiten Anmeldung nicht verfügbar

Veröffentlicht von

Last Updated on 29. Juni 2022 by Sebastian

Mir ist es jetzt schon das zweite Mal passiert das ich bei einem Kunden FSlogix implementiert habe und nach der zweiten Anmeldung reagierte das Startmenü nicht mehr. Wenn man danach googelt findet man tatsächlich ein Beitrag von Manuel Winkel in dem er auf einen Beitrag von James Rankin verweist das wohl eine Exclusion in der Redirections.xml dafür verantwortlich ist. Genauer geht es in diesem Fall um den Ordner \AppData\Local\GroupPolicy. Dieser Ordner wird in den meisten Konfigurationen ausgenommen und enthält eine lokaler Cache der Gruppenrichtlinien. In dem Beispiel geht das Betriebsystem also davon aus das ein Cache der GPOs vorhanden sein soll, da dies nicht der Fall ist schlagen diverse Fehler auf darunter auch ein Startmenü das nicht aufgeht.

Der Fehler war allerdings bei mir etwas anders. Ich hatte zwar auch diese Ausnahme in meiner exclusions.xml aber ein entfernen eben dieser exclusion brachte keine änderung. Windows Images werden häufig für den Einsatz in Citrix oder Horizon Umgebungen optimiert. Das bedeutet das häufig Dienste abgeschaltet werden. Es hat sich wohl irgendwann zwischen Windows 10 1507 und 1803 eingeschlichen auch den App Readiness Dienst oder auch App-Vorbereitung zu Deaktivieren. Das abschalten des Dienstes hat den gleichen Nebeneffekt wie der von Manuel und James beschriebenen Problematik aber ist der Tatsache geschuldet Dienste teilweise aus Performancegründen einfach abgeschaltet werden.

Der Dienste sollte als entweder im Image direkt oder via GPO wieder aktiviert werden und das Problem sollte nach einem Neustart behoben sein.

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.